Si yo pienso lo mismo, pero cual sería la solución, desinstalar python, 2.6.5 e instalar 2.7.x? no sería peligroso para el sistema? si hay algún scrip o programa que utilice la versión vieja funcionará con la nueva? supongo que si.<br>
como lo actualizo? en los repositorios de ubuntu licid no está python 2.7.x <br><br><div class="gmail_quote">El 21 de noviembre de 2012 23:37, claudio canepa <span dir="ltr"><<a href="mailto:ccanepacc@gmail.com" target="_blank">ccanepacc@gmail.com</a>></span> escribió:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br><br><div class="gmail_quote"><div class="im">2012/11/21 Jesús Francisco <span dir="ltr"><<a href="mailto:jgomo3@gmail.com" target="_blank">jgomo3@gmail.com</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
El 21 de noviembre de 2012 18:13, Eduardo Sandulli <span dir="ltr"><<a href="mailto:eduardosandulli@gmail.com" target="_blank">eduardosandulli@gmail.com</a>></span> escribió:<br><div class="gmail_extra"><div class="gmail_quote">

<div>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



que tal!<br>No se si esta es la lista correcta para hacer eta pregunta pero tal ves puedan ayudarme. Alguno conoce SOZI?<br>
Es una exención de inkscape para hacer presentaciones tipo pressi, muy piola! está hecha en python<br>
El tema es la he instalado en Ubuntu 10.04 y no consigo hacerla funcionar, me tira el siguiente error:<br>Traceback (most recent call last):<br>  File "/usr/share/inkscape/extensions/sozi.py", line 30, in <module><br>





    from sozi.document import *<br>  File "/usr/share/inkscape/extensions/sozi/document.py", line 81<br>    self.layers = { l.attrib[group_attr] : SoziLayer(self, l) for l in self.xml.xpath("sozi:layer", namespaces=inkex.NSS) if group_attr in l.attrib }<br>





                                                                ^<br>SyntaxError: invalid syntax<br><br></blockquote></div></blockquote><div><br></div></div><div>Mis apuestan van a la versión de Python. Creo que esa sintaxis de Diccionarios por comprensión es de Python 2.7, y por la versión de Ubuntu que estás utilizando, probablemente no tengas instalada la versión de Python necesaria para ello.</div>



<div><br></div></div></div></blockquote><div><br></div></div><div>Si, ese estilo de definir un dict solo esta disponible en python  2.7+</div><div><br></div><div>Probando:</div><div><br></div><div> Python 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)] on win32<br>

Type "help", "copyright", "credits" or "license" for more information.<br>>>> d = {i:i for i in range(10)}<br>  File "<stdin>", line 1<br>    d = {i:i for i in range(10)}<br>

               ^<br>SyntaxError: invalid syntax</div><div><br></div><div><br></div><div>Python 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)] on win32<br>Type "help", "copyright", "credits" or "license" for more information.<br>

>>> d = {i:i for i in range(10)}<br>>>><br>>>> d<br>{0: 0, 1: 1, 2: 2, 3: 3, 4: 4, 5: 5, 6: 6, 7: 7, 8: 8, 9: 9}<br>>>></div><div><br></div></div>
<br>_______________________________________________<br>
pyar mailing list <a href="mailto:pyar@python.org.ar">pyar@python.org.ar</a><br>
<a href="http://listas.python.org.ar/listinfo/pyar" target="_blank">http://listas.python.org.ar/listinfo/pyar</a><br>
<br>
PyAr - Python Argentina - Sitio web: <a href="http://www.python.org.ar/" target="_blank">http://www.python.org.ar/</a><br>
<br>
La lista de PyAr esta Hosteada en USLA - Usuarios de Software Libre de Argentina - <a href="http://www.usla.org.ar" target="_blank">http://www.usla.org.ar</a><br></blockquote></div><br><br clear="all"><br>-- <br>Cultura Libre!! lo demás no importa nada.<br>
<br>